Discussion:
03/03: gnu: libinput: Update to 1.9.3.
(too old to reply)
Mark H Weaver
2017-12-09 01:36:27 UTC
Permalink
Raw Message
***@flashner.co.il (Efraim Flashner) writes:

> efraim pushed a commit to branch master
> in repository guix.
>
> commit 5f5083749c1ff2731e84fa7d8eea182ad45c18a5
> Author: Efraim Flashner <***@flashner.co.il>
> Date: Fri Dec 8 09:25:40 2017 +0200
>
> gnu: libinput: Update to 1.9.3.
>
> * gnu/packages/freedesktop.scm (libinput): Update to 1.9.3.
> [build-system]: Switch to meson-build-system.

FYI, switching to 'meson-build-system' here caused around 120+ more
dependency failures on armhf-linux, including xf86-input-libinput, since
we've never successfully built 'ninja' on armhf-linux. So, we've
essentially just lost graphics support on armhf-linux.

Mark
Efraim Flashner
2017-12-10 11:11:54 UTC
Permalink
Raw Message
On Fri, Dec 08, 2017 at 08:36:27PM -0500, Mark H Weaver wrote:
> ***@flashner.co.il (Efraim Flashner) writes:
>
> > efraim pushed a commit to branch master
> > in repository guix.
> >
> > commit 5f5083749c1ff2731e84fa7d8eea182ad45c18a5
> > Author: Efraim Flashner <***@flashner.co.il>
> > Date: Fri Dec 8 09:25:40 2017 +0200
> >
> > gnu: libinput: Update to 1.9.3.
> >
> > * gnu/packages/freedesktop.scm (libinput): Update to 1.9.3.
> > [build-system]: Switch to meson-build-system.
>
> FYI, switching to 'meson-build-system' here caused around 120+ more
> dependency failures on armhf-linux, including xf86-input-libinput, since
> we've never successfully built 'ninja' on armhf-linux. So, we've
> essentially just lost graphics support on armhf-linux.
>
> Mark

1.8.3 is the last version that still has autotools support, it was
removed in the 1.9 branch. Unfortunately I don't have access to an armhf
machine to try to fix the armhf build of ninja. I suspect that this is
going to be an issue going forward, as more packages move to a meson
build system.

I'm not against downgrading to 1.8.3 in the mean time to keep the
packages that depend on libinput{,-minimal} available to armhf users,
but it is something that's going to need to be addressed sooner rather
than later.

--
Efraim Flashner <***@flashner.co.il> א׀ךים ׀לשנך
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
Ludovic Courtès
2017-12-11 09:33:23 UTC
Permalink
Raw Message
Hi,

Efraim Flashner <***@flashner.co.il> skribis:

> On Fri, Dec 08, 2017 at 08:36:27PM -0500, Mark H Weaver wrote:
>> ***@flashner.co.il (Efraim Flashner) writes:
>>
>> > efraim pushed a commit to branch master
>> > in repository guix.
>> >
>> > commit 5f5083749c1ff2731e84fa7d8eea182ad45c18a5
>> > Author: Efraim Flashner <***@flashner.co.il>
>> > Date: Fri Dec 8 09:25:40 2017 +0200
>> >
>> > gnu: libinput: Update to 1.9.3.
>> >
>> > * gnu/packages/freedesktop.scm (libinput): Update to 1.9.3.
>> > [build-system]: Switch to meson-build-system.
>>
>> FYI, switching to 'meson-build-system' here caused around 120+ more
>> dependency failures on armhf-linux, including xf86-input-libinput, since
>> we've never successfully built 'ninja' on armhf-linux. So, we've
>> essentially just lost graphics support on armhf-linux.
>>
>> Mark
>
> 1.8.3 is the last version that still has autotools support, it was
> removed in the 1.9 branch. Unfortunately I don't have access to an armhf
> machine to try to fix the armhf build of ninja. I suspect that this is
> going to be an issue going forward, as more packages move to a meson
> build system.
>
> I'm not against downgrading to 1.8.3 in the mean time to keep the
> packages that depend on libinput{,-minimal} available to armhf users,
> but it is something that's going to need to be addressed sooner rather
> than later.

Maybe the safe approach is to revert now so armhf users get graphics
back, take time to investigate and fix the Ninja build failures on ARM
(surely there are patches floating around on the intertubes), and then
reinstate the upgrade.

How does that sound?

(Note that I’m volunteering, but hey! ;-))

Ludo’.
Loading...